use CPPFLAGS
[osspd.git] / debian / patches / 0001-Fix-compilation-with-Werror-format-security-use-CPPF.patch
1 From: Ralf Jung <post@ralfj.de>
2 Date: Thu, 13 Sep 2012 18:36:54 +0200
3 Subject: Fix compilation with -Werror=format-security, use CPPFLAGS
4
5 ---
6  Makefile     |    2 +-
7  ossp-slave.c |    4 ++--
8  osspd.c      |    2 +-
9  3 files changed, 4 insertions(+), 4 deletions(-)
10
11 diff --git a/Makefile b/Makefile
12 index 8111c9b..8d8fe87 100644
13 --- a/Makefile
14 +++ b/Makefile
15 @@ -2,7 +2,7 @@
16  # DESTDIR is completely respected
17  CC := gcc
18  AR := ar
19 -CFLAGS := -Wall $(CFLAGS)
20 +CFLAGS := -Wall $(CFLAGS) $(CPPFLAGS)
21  XLDFLAGS := $(LDFLAGS)
22  LDFLAGS := -L. -lossp $(LDFLAGS)
23  prefix := /usr/local
24 diff --git a/ossp-slave.c b/ossp-slave.c
25 index 4c5cb2d..a290636 100644
26 --- a/ossp-slave.c
27 +++ b/ossp-slave.c
28 @@ -89,7 +89,7 @@ void ossp_slave_init(int argc, char **argv)
29         }
30  
31         if (!have_uid || !have_gid || ossp_cmd_fd < 0 || ossp_notify_fd < 0) {
32 -               fprintf(stderr, usage);
33 +               fputs(usage, stderr);
34                 _exit(1);
35         }
36  
37 @@ -105,7 +105,7 @@ void ossp_slave_init(int argc, char **argv)
38                 void *p;
39  
40                 if (!mmap_off || !mmap_size) {
41 -                       fprintf(stderr, usage);
42 +                       fputs(usage, stderr);
43                         _exit(1);
44                 }
45  
46 diff --git a/osspd.c b/osspd.c
47 index 37c9b35..1dbe586 100644
48 --- a/osspd.c
49 +++ b/osspd.c
50 @@ -2109,7 +2109,7 @@ static int process_arg(void *data, const char *arg, int key,
51  
52         switch (key) {
53         case 0:
54 -               fprintf(stderr, usage);
55 +               fputs(usage, stderr);
56                 param->help = 1;
57                 return 0;
58         case 1: