3 SLAVESDIR=/usr/lib/osspd
4 UDEVDIR=/lib/udev/rules.d
7 dh $@ --parallel --with=systemd
9 override_dh_auto_build:
10 dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
12 override_dh_auto_install:
13 dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
16 dh_strip --ddeb-migration='osspd-dbg (<< 1.3.2-7~)'
19 dh_install --fail-missing
20 # adding kmod integration
21 install -D -m 0644 debian/osspd.kmod debian/osspd/lib/modules-load.d/osspd.conf
23 # Disable tests, they require running the osspd
24 override_dh_auto_test: