Add -pthread compiler and linker flag
[osspd.git] / debian / patches / 0005-Add-pthread-compiler-and-linker-flag.patch
1 From: Ralf Jung <post@ralfj.de>
2 Date: Sat, 11 May 2013 14:24:17 +0200
3 Subject: Add -pthread compiler and linker flag
4
5 (based on patch in Ubuntu by Logan Rosen <logan@ubuntu.com>)
6 ---
7  Makefile |    4 ++--
8  1 file changed, 2 insertions(+), 2 deletions(-)
9
10 diff --git a/Makefile b/Makefile
11 index 236176e..11f2836 100644
12 --- a/Makefile
13 +++ b/Makefile
14 @@ -2,9 +2,9 @@
15  # DESTDIR is completely respected
16  CC := gcc
17  AR := ar
18 -CFLAGS := -Wall $(CFLAGS) $(CPPFLAGS)
19 +CFLAGS := -Wall -pthread $(CFLAGS) $(CPPFLAGS)
20  XLDFLAGS := $(LDFLAGS)
21 -LDFLAGS := -L. -lossp $(LDFLAGS)
22 +LDFLAGS := -L. -lossp -pthread $(LDFLAGS)
23  prefix := /usr/local
24  DESTDIR :=
25  UDEVDIR := /etc/udev/rules.d