move backends into their own packages
[osspd.git] / debian / rules
1 #!/usr/bin/make -f
2
3 SLAVESDIR=/usr/lib/osspd
4 UDEVDIR=/lib/udev/rules.d
5
6 %:
7         dh $@ --parallel
8
9 override_dh_auto_build:
10         dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
11
12 override_dh_auto_install:
13         dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
14
15 override_dh_strip:
16         dh_strip --dbg-package=osspd-dbg
17
18 override_dh_install:
19         dh_install --fail-missing
20
21 # Disable tests, they require running the osspd
22 override_dh_auto_test: