finish up changelog for release
[osspd.git] / debian / patches / 0005-Add-pthread-compiler-and-linker-flag.patch
1 From: Ralf Jung <post@ralfj.de>
2 Date: Sat, 11 May 2013 14:24:17 +0200
3 Subject: Add -pthread compiler and linker flag
4
5 (based on patch in Ubuntu by Logan Rosen <logan@ubuntu.com>)
6 Forwarded: http://sourceforge.net/mailarchive/forum.php?thread_name=518E3901.8050206%40ralfj.de&forum_name=osspd-users
7 ---
8  Makefile | 4 ++--
9  1 file changed, 2 insertions(+), 2 deletions(-)
10
11 diff --git a/Makefile b/Makefile
12 index 236176e..11f2836 100644
13 --- a/Makefile
14 +++ b/Makefile
15 @@ -2,9 +2,9 @@
16  # DESTDIR is completely respected
17  CC := gcc
18  AR := ar
19 -CFLAGS := -Wall $(CFLAGS) $(CPPFLAGS)
20 +CFLAGS := -Wall -pthread $(CFLAGS) $(CPPFLAGS)
21  XLDFLAGS := $(LDFLAGS)
22 -LDFLAGS := -L. -lossp $(LDFLAGS)
23 +LDFLAGS := -L. -lossp -pthread $(LDFLAGS)
24  prefix := /usr/local
25  DESTDIR :=
26  UDEVDIR := /etc/udev/rules.d