finish up changelog for release
[osspd.git] / debian / rules
index bbbb745dae566b069193df60dd025c2f66065f2f..2a3824085b541a343241ea020af92ed77d5a747f 100755 (executable)
@@ -4,7 +4,7 @@ SLAVESDIR=/usr/lib/osspd
 UDEVDIR=/lib/udev/rules.d
 
 %:
-       dh $@ --parallel --with=systemd
+       dh $@
 
 override_dh_auto_build:
        dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
@@ -13,10 +13,12 @@ override_dh_auto_install:
        dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
 
 override_dh_strip:
-       dh_strip --dbg-package=osspd-dbg
+       dh_strip --ddeb-migration='osspd-dbg (<< 1.3.2-7~)'
 
 override_dh_install:
-       dh_install --fail-missing
+       dh_install
+       # adding kmod integration
+       install -D -m 0644 debian/osspd.kmod debian/osspd/lib/modules-load.d/osspd.conf
 
 # Disable tests, they require running the osspd
 override_dh_auto_test: