add a systemd service file (taken from Arch)
[osspd.git] / debian / rules
index 485e7a9806f347faf077f84653af248ab863bade..bbbb745dae566b069193df60dd025c2f66065f2f 100755 (executable)
@@ -1,7 +1,22 @@
 #!/usr/bin/make -f
 
+SLAVESDIR=/usr/lib/osspd
+UDEVDIR=/lib/udev/rules.d
+
 %:
-       dh $@ --parallel
+       dh $@ --parallel --with=systemd
+
+override_dh_auto_build:
+       dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
+override_dh_auto_install:
+       dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
+override_dh_strip:
+       dh_strip --dbg-package=osspd-dbg
+
+override_dh_install:
+       dh_install --fail-missing
 
 # Disable tests, they require running the osspd
 override_dh_auto_test: