use CPPFLAGS
[osspd.git] / debian / patches / 0001-Fix-compilation-with-Werror-format-security-use-CPPF.patch
similarity index 67%
rename from debian/patches/0001-Fix-compilation-with-Werror-format-security.patch
rename to debian/patches/0001-Fix-compilation-with-Werror-format-security-use-CPPF.patch
index d688de1e86202f7f5974b4531e441fc97eccf57e..2fcf036e7ffeca4b9261320b3a1d1937f2218930 100644 (file)
@@ -1,12 +1,26 @@
 From: Ralf Jung <post@ralfj.de>
 Date: Thu, 13 Sep 2012 18:36:54 +0200
-Subject: Fix compilation with -Werror=format-security
+Subject: Fix compilation with -Werror=format-security, use CPPFLAGS
 
 ---
+ Makefile     |    2 +-
  ossp-slave.c |    4 ++--
  osspd.c      |    2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
3 files changed, 4 insertions(+), 4 deletions(-)
 
+diff --git a/Makefile b/Makefile
+index 8111c9b..8d8fe87 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ # DESTDIR is completely respected
+ CC := gcc
+ AR := ar
+-CFLAGS := -Wall $(CFLAGS)
++CFLAGS := -Wall $(CFLAGS) $(CPPFLAGS)
+ XLDFLAGS := $(LDFLAGS)
+ LDFLAGS := -L. -lossp $(LDFLAGS)
+ prefix := /usr/local
 diff --git a/ossp-slave.c b/ossp-slave.c
 index 4c5cb2d..a290636 100644
 --- a/ossp-slave.c