projects
/
osspd.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
make pulseaudio a Recommends:
[osspd.git]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index 4f5c219f212a436a9c697c1c9ab2e61180b2650b..2f99a91892cac5d406d80242eb3a747ab72ee0f9 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-1,12
+1,22
@@
#!/usr/bin/make -f
#!/usr/bin/make -f
-export DH_VERBOSE=1
+SLAVESDIR=/usr/lib/osspd
+UDEVDIR=/lib/udev/rules.d
%:
dh $@ --parallel
%:
dh $@ --parallel
+override_dh_auto_build:
+ dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
override_dh_auto_install:
override_dh_auto_install:
- dh_auto_install -- prefix=/usr UDEVDIR=/lib/udev/rules.d
+ dh_auto_install --destdir=debian/osspd -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
+override_dh_strip:
+ dh_strip --dbg-package=osspd-dbg
+
+override_dh_installdocs:
+ dh_installdocs --link-doc=osspd
# Disable tests, they require running the osspd
override_dh_auto_test:
# Disable tests, they require running the osspd
override_dh_auto_test: