use CPPFLAGS
[osspd.git] / debian / patches / 0001-Fix-compilation-with-Werror-format-security-use-CPPF.patch
diff --git a/debian/patches/0001-Fix-compilation-with-Werror-format-security-use-CPPF.patch b/debian/patches/0001-Fix-compilation-with-Werror-format-security-use-CPPF.patch
new file mode 100644 (file)
index 0000000..2fcf036
--- /dev/null
@@ -0,0 +1,58 @@
+From: Ralf Jung <post@ralfj.de>
+Date: Thu, 13 Sep 2012 18:36:54 +0200
+Subject: Fix compilation with -Werror=format-security, use CPPFLAGS
+
+---
+ Makefile     |    2 +-
+ ossp-slave.c |    4 ++--
+ osspd.c      |    2 +-
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8111c9b..8d8fe87 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ # DESTDIR is completely respected
+ CC := gcc
+ AR := ar
+-CFLAGS := -Wall $(CFLAGS)
++CFLAGS := -Wall $(CFLAGS) $(CPPFLAGS)
+ XLDFLAGS := $(LDFLAGS)
+ LDFLAGS := -L. -lossp $(LDFLAGS)
+ prefix := /usr/local
+diff --git a/ossp-slave.c b/ossp-slave.c
+index 4c5cb2d..a290636 100644
+--- a/ossp-slave.c
++++ b/ossp-slave.c
+@@ -89,7 +89,7 @@ void ossp_slave_init(int argc, char **argv)
+       }
+       if (!have_uid || !have_gid || ossp_cmd_fd < 0 || ossp_notify_fd < 0) {
+-              fprintf(stderr, usage);
++              fputs(usage, stderr);
+               _exit(1);
+       }
+@@ -105,7 +105,7 @@ void ossp_slave_init(int argc, char **argv)
+               void *p;
+               if (!mmap_off || !mmap_size) {
+-                      fprintf(stderr, usage);
++                      fputs(usage, stderr);
+                       _exit(1);
+               }
+diff --git a/osspd.c b/osspd.c
+index 37c9b35..1dbe586 100644
+--- a/osspd.c
++++ b/osspd.c
+@@ -2109,7 +2109,7 @@ static int process_arg(void *data, const char *arg, int key,
+       switch (key) {
+       case 0:
+-              fprintf(stderr, usage);
++              fputs(usage, stderr);
+               param->help = 1;
+               return 0;
+       case 1: