move backends into their own packages
[osspd.git] / debian / rules
index ce2eb52beb5d7b9bfcad988ea41fd7e44f1b2b97..5bb1cf5097c36402c46f1dbb3591aeaa3c5f33e7 100755 (executable)
@@ -1,4 +1,22 @@
 #!/usr/bin/make -f
 
+SLAVESDIR=/usr/lib/osspd
+UDEVDIR=/lib/udev/rules.d
+
 %:
        dh $@ --parallel
+
+override_dh_auto_build:
+       dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
+override_dh_auto_install:
+       dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
+override_dh_strip:
+       dh_strip --dbg-package=osspd-dbg
+
+override_dh_install:
+       dh_install --fail-missing
+
+# Disable tests, they require running the osspd
+override_dh_auto_test: