Install slaves to /usr/lib/osspd: They are not means to be called
[osspd.git] / debian / rules
index ce2eb52beb5d7b9bfcad988ea41fd7e44f1b2b97..ba13a354129e88d94244b465a99c165752e4c619 100755 (executable)
@@ -1,4 +1,16 @@
 #!/usr/bin/make -f
 
+SLAVESDIR=/usr/lib/osspd
+UDEVDIR=/lib/udev/rules.d
+
 %:
        dh $@ --parallel
+
+override_dh_auto_build:
+       dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
+override_dh_auto_install:
+       dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
+# Disable tests, they require running the osspd
+override_dh_auto_test: