Create a debug package
[osspd.git] / debian / rules
index ce2eb52beb5d7b9bfcad988ea41fd7e44f1b2b97..2f99a91892cac5d406d80242eb3a747ab72ee0f9 100755 (executable)
@@ -1,4 +1,22 @@
 #!/usr/bin/make -f
 
+SLAVESDIR=/usr/lib/osspd
+UDEVDIR=/lib/udev/rules.d
+
 %:
        dh $@ --parallel
+
+override_dh_auto_build:
+       dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
+override_dh_auto_install:
+       dh_auto_install --destdir=debian/osspd -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+
+override_dh_strip:
+       dh_strip --dbg-package=osspd-dbg
+
+override_dh_installdocs:
+       dh_installdocs --link-doc=osspd
+
+# Disable tests, they require running the osspd
+override_dh_auto_test: