projects
/
osspd.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
fix build on MIPS
[osspd.git]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index 5bb1cf5097c36402c46f1dbb3591aeaa3c5f33e7..9b9a0a11b75e7ffad99c73374b278a226027e1a6 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-4,7
+4,7
@@
SLAVESDIR=/usr/lib/osspd
UDEVDIR=/lib/udev/rules.d
%:
UDEVDIR=/lib/udev/rules.d
%:
- dh $@ --parallel
+ dh $@ --parallel
--with=systemd
override_dh_auto_build:
dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
override_dh_auto_build:
dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
@@
-13,10
+13,12
@@
override_dh_auto_install:
dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
override_dh_strip:
dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
override_dh_strip:
- dh_strip --d
bg-package=osspd-dbg
+ dh_strip --d
deb-migration='osspd-dbg (<< 1.3.2-7~)'
override_dh_install:
dh_install --fail-missing
override_dh_install:
dh_install --fail-missing
+ # adding kmod integration
+ install -D -m 0644 debian/osspd.kmod debian/osspd/lib/modules-load.d/osspd.conf
# Disable tests, they require running the osspd
override_dh_auto_test:
# Disable tests, they require running the osspd
override_dh_auto_test: