update to dh compat level 13
[osspd.git] / debian / rules
index ba13a354129e88d94244b465a99c165752e4c619..9150e8430fd5849fb1be8c509de02160c8bfb59a 100755 (executable)
@@ -12,5 +12,13 @@ override_dh_auto_build:
 override_dh_auto_install:
        dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
 
+override_dh_strip:
+       dh_strip --ddeb-migration='osspd-dbg (<< 1.3.2-7~)'
+
+override_dh_install:
+       dh_install
+       # adding kmod integration
+       install -D -m 0644 debian/osspd.kmod debian/osspd/lib/modules-load.d/osspd.conf
+
 # Disable tests, they require running the osspd
 override_dh_auto_test: