Migrate debug symbols to ddeb
[osspd.git] / debian / rules
index ba13a354129e88d94244b465a99c165752e4c619..9b9a0a11b75e7ffad99c73374b278a226027e1a6 100755 (executable)
@@ -4,7 +4,7 @@ SLAVESDIR=/usr/lib/osspd
 UDEVDIR=/lib/udev/rules.d
 
 %:
-       dh $@ --parallel
+       dh $@ --parallel --with=systemd
 
 override_dh_auto_build:
        dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
@@ -12,5 +12,13 @@ override_dh_auto_build:
 override_dh_auto_install:
        dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
 
+override_dh_strip:
+       dh_strip --ddeb-migration='osspd-dbg (<< 1.3.2-7~)'
+
+override_dh_install:
+       dh_install --fail-missing
+       # adding kmod integration
+       install -D -m 0644 debian/osspd.kmod debian/osspd/lib/modules-load.d/osspd.conf
+
 # Disable tests, they require running the osspd
 override_dh_auto_test: