Update Standards-Version to 3.9.4. No changes needed.
[osspd.git] / debian / rules
index ba13a354129e88d94244b465a99c165752e4c619..08a897387975b58ac468fde5b1cbd3cc56faa59f 100755 (executable)
@@ -4,7 +4,7 @@ SLAVESDIR=/usr/lib/osspd
 UDEVDIR=/lib/udev/rules.d
 
 %:
-       dh $@ --parallel
+       dh $@ --parallel --with=systemd
 
 override_dh_auto_build:
        dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
@@ -12,5 +12,18 @@ override_dh_auto_build:
 override_dh_auto_install:
        dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
 
+override_dh_strip:
+       dh_strip --dbg-package=osspd-dbg
+
+override_dh_installdocs:
+       mkdir -p debian/osspd-dbg/usr/share/doc
+       ln -s osspd debian/osspd-dbg/usr/share/doc/osspd-dbg
+       dh_installdocs
+
+override_dh_install:
+       dh_install --fail-missing
+       # adding kmod integration
+       install -D -m 0644 debian/osspd.kmod debian/osspd/lib/modules-load.d/osspd.conf
+
 # Disable tests, they require running the osspd
 override_dh_auto_test: