projects
/
osspd.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
add a systemd service file (taken from Arch)
[osspd.git]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index 2f99a91892cac5d406d80242eb3a747ab72ee0f9..bbbb745dae566b069193df60dd025c2f66065f2f 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-4,19
+4,19
@@
SLAVESDIR=/usr/lib/osspd
UDEVDIR=/lib/udev/rules.d
%:
UDEVDIR=/lib/udev/rules.d
%:
- dh $@ --parallel
+ dh $@ --parallel
--with=systemd
override_dh_auto_build:
dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
override_dh_auto_install:
override_dh_auto_build:
dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
override_dh_auto_install:
- dh_auto_install --
destdir=debian/osspd --
prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+ dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
override_dh_strip:
dh_strip --dbg-package=osspd-dbg
override_dh_strip:
dh_strip --dbg-package=osspd-dbg
-override_dh_install
docs
:
- dh_install
docs --link-doc=osspd
+override_dh_install:
+ dh_install
--fail-missing
# Disable tests, they require running the osspd
override_dh_auto_test:
# Disable tests, they require running the osspd
override_dh_auto_test: