projects
/
osspd.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
update to dh compat level 13
[osspd.git]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index 2f99a91892cac5d406d80242eb3a747ab72ee0f9..9150e8430fd5849fb1be8c509de02160c8bfb59a 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-10,13
+10,15
@@
override_dh_auto_build:
dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
override_dh_auto_install:
dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
override_dh_auto_install:
- dh_auto_install --
destdir=debian/osspd --
prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
+ dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
override_dh_strip:
override_dh_strip:
- dh_strip --d
bg-package=osspd-dbg
+ dh_strip --d
deb-migration='osspd-dbg (<< 1.3.2-7~)'
-override_dh_installdocs:
- dh_installdocs --link-doc=osspd
+override_dh_install:
+ dh_install
+ # adding kmod integration
+ install -D -m 0644 debian/osspd.kmod debian/osspd/lib/modules-load.d/osspd.conf
# Disable tests, they require running the osspd
override_dh_auto_test:
# Disable tests, they require running the osspd
override_dh_auto_test: