finish up changelog for release
[osspd.git] / debian / rules
1 #!/usr/bin/make -f
2
3 SLAVESDIR=/usr/lib/osspd
4 UDEVDIR=/lib/udev/rules.d
5
6 %:
7         dh $@
8
9 override_dh_auto_build:
10         dh_auto_build -- SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
11
12 override_dh_auto_install:
13         dh_auto_install -- prefix=/usr SLAVESDIR=$(SLAVESDIR) UDEVDIR=$(UDEVDIR)
14
15 override_dh_strip:
16         dh_strip --ddeb-migration='osspd-dbg (<< 1.3.2-7~)'
17
18 override_dh_install:
19         dh_install
20         # adding kmod integration
21         install -D -m 0644 debian/osspd.kmod debian/osspd/lib/modules-load.d/osspd.conf
22
23 # Disable tests, they require running the osspd
24 override_dh_auto_test: